Home » Server Options » Streams & AQ » AQ Dequeue fails (Oracle 11g Release, Linux 2.6.18-53.el5 x86_64 GNU/Linux)
AQ Dequeue fails [message #424328] Thu, 01 October 2009 10:12
Messages: 1
Registered: October 2009
Junior Member
We`ve been running AQ for about 6 months now, and it`s been working without any major problems. But suddenly a couple of days ago, the dequeue-process stopped, with this I mean that the dequeue never got triggered. The enqueue works like it should. I don`t know too much in details of how the AQ works "behind the scene".
I can dequeue from the AQ-tabele manually without any problems with the DBMS_AQ.DEQUEUE-package, but this kind of removes the whole advantage using AQ.
Is there any processes that may be missing (that I can see with top/ps cmd)?
We`ve also tried a reboot of the database, and when we trigged the enqueue, a session with the call to the dequeue (which is a procedure inside a pacaked) was shown but only wating with the wait "Streams AQ: waiting for messages in the queue", and the session stayed like this for 10 hours before we finally killed it manually. We`ve also tried to recreate the AQ-table/dequeue/enqueue/subscriber, but with the same result.
Does anyone have any suggestion/tip? Any suggestions are appreciated, and thank you for your time reading this.

Previous Topic: AQ queues
Next Topic: Using AQ from java: jms vs. jdbc
Goto Forum:

Current Time: Sun Jan 29 13:16:27 CST 2023