Home » Developer & Programmer » Application Express, ORDS & MOD_PLSQL » ID in procedure after submit is NULL
ID in procedure after submit is NULL [message #510984] Wed, 08 June 2011 17:52 Go to next message
Messages: 60
Registered: March 2005
I have a form based on a table, where a sequence supplies the TABLE_ID.
The field TABLE_ID is empty at the time of pressing the button CREATE.

In the processes "after submit" I have a PL/SQL
which selects from a view based on this TABLE_ID.
For testing I write the TABLE_ID in the same PL/SQL into an audit table ...and TABLE_ID is NULL

How can I solve this problem ? I need to execute a procedure which uses already this TABLE_ID.
Re: ID in procedure after submit is NULL [message #511070 is a reply to message #510984] Thu, 09 June 2011 07:11 Go to previous message
Messages: 255
Registered: August 2007
Senior Member
If you look at the "Process row of XXX" process in your page you should see a field called "return key into item".
Try to give in an item here, and you can use that item in your other process. (This process would have to be run after your insert)

(I am running version 4 of apex though. I haven't tried this on earlier versions, but you could have a look at least)
Previous Topic: how do i run a procedure in sql apex
Next Topic: Popup/New Window - APEX page
Goto Forum:

Current Time: Tue May 21 20:34:46 CDT 2024