Home » Server Options » Streams & AQ » advanced queue :::: HELP ME:::::
advanced queue :::: HELP ME::::: [message #50317] Mon, 11 March 2002 06:30 Go to next message
Messages: 1
Registered: March 2002
Junior Member
when i want to create a queue table(create_queue_table), oralce give me a error message. this message is follow.
ORA-00439: Funktion nicht aktiviert(functoin not active): Database queuing
ORA-06512: in "SYS.DBMS_AQADM_SYS", Zeile 2012
ORA-06512: in "SYS.DBMS_AQADM", Zeile 55
ORA-06512: in Zeile 2
did you know any body solution ??
Re: advanced queue :::: HELP ME::::: [message #50397 is a reply to message #50317] Wed, 13 March 2002 22:17 Go to previous message
from www.asktom.oracle.c
Messages: 2
Registered: March 2002
Junior Member
Murali -- Thanks for the question regarding "Advanced queuing", version
You Asked


I am using Oracle on NT

When i run the following query, feature not enabled error is


ERROR at line 1:
ORA-00439: feature not enabled:
ORA-06512: at "SYS.DBMS_AQADM", line 1477
ORA-06512: at line 1

When i check V$OPTIONS Database queuing is set to FALSE

Is this is the problem..? Will AQ will work with Workgroup

Please help

Thanks & Regards


and we said...

In 8.0, AQ was part of enterprise and not standard.


for the feature/function breakout between the two for 8.0. For
8.1, see

in that AQ is no longer broken out -- its in both.

Was this response helpful to you? Let us know! Reviews

enterprise edition with typical installation and feature still not enabled February 24, 2002
Reviewer: coskan from turkey

i have already installed the 8.1.7 enterprise edition which i have downloaded
from otn and without any product licence i am using it for development
the aq support is not enabled in v$option table also when i ran the script
dbmsaqad.sql from rdmbs/admin it is still false in the v$option but the error
message has been changed
BEGIN dbms_aqadm.create_queue_table (queue_table => 'AppOne_QTab',
multiple_consumers => true, queue_payload_type => 'RAW'); END;

ERROR at line 1:
ORA-04068: existing state of packages has been discarded
ORA-04061: existing state of package "SYS.DBMS_AQADM_SYS" has been invalidated
ORA-04065: not executed, altered or dropped package "SYS.DBMS_AQADM_SYS"
ORA-06508: PL/SQL: could not find program unit being called
ORA-06512: at "SYS.DBMS_AQADM", line 55
ORA-06512: at line 1

why this happens then does it impossible to use aq without a metalink account?
ps: and i think no one in oracle corporation knows this because no one could
answer my question

I think you just installed something wrong.

You give no operating system but I would guess (since you don't give me a
history of how you got from here to there) that you tried to upgrade a SE
database to EE and didn't follow all of the steps.

It looks like you might not have relinked the database executables (else
v$option would reflect Database queueing as true, that gets done at LINK time).

Also, necessary catalog scripts (eg: catqueue.sql) were not executed.

Typically the reason people cannot answer questions is due to insufficient
information. Everything can be answered, given sufficient input data.

Suggest you either supply a HISTORY of what you've done exactly to get to where
you are OR you start over with a clean install and a fresh database, I can
assure you AQ will be there.

typical installation or manual with cat scripts February 24, 2002
Reviewer: coskan from turkey

if i ask again like this way i think it would be more open.
operating system is win2000 pro sp2
installation is typical with database creation included
no any upgrade clean install
and the installation guides says that it is included with typical installation.
also advanced replication is set to false too.
do i have to run the cat scripts manualy?
doesn't the universal installer do it for me ?
the only thing i am trying to do is to run the scripts in the "step by step b2b
application" which is in the "xml applications" guide.
i am new with oracle and take your time but my graduation project is about b2b
application and advanced queueing is needed.

show me the output of:

c:> sqlplus system/manager

(i want to see the cut and paste of the SQLPlus banner that shows up)

as well as:

select * from v$version;
select * from v$option;
Previous Topic: advanced queue tables
Next Topic: Exception Queues in Advanced Queuing
Goto Forum:

Current Time: Sat Apr 01 10:02:28 CDT 2023