Home » Infrastructure » Linux » RAC and OCFS2 (RHEL 5.9 and Oracle 11Gr2)
RAC and OCFS2 [message #593760] Tue, 20 August 2013 12:06 Go to next message
Messages: 1
Registered: August 2013
Junior Member
I have a two node Oracle RAC cluster that uses OCFS2, and we had to expand a volume on one of the DB's that is an Iscsi DELL Equallogic SAN Volume. We succesfully expanded the drive, but had to restore the data from a cold backup. Also had to re-create the OCFS2 file system. Since then we have been seeing these ocfs errors in /var/log/messages directory. See below.
[b]ocfs2_queue_orphans:1631 ERROR: status = -2
Aug 20 10:29:52 mdm-oracle1-prod kernel: (ocfs2_wq,5220,1):ocfs2_recover_orphans:1730 ERROR: status = -2
Aug 20 10:29:52 mdm-oracle1-prod kernel: (ocfs2_wq,5220,1):ocfs2_complete_recovery:897 ERROR: status = -2[/b.]
I tried googling these errors, but didn't get much for whether they are serious or not. So I offlined the DB's last night and tried running an fsck -ocfs2 -f /dev/sdx after dismounting the file system and device. Got the standard warning message about possible data loss. I had done another cold backup at that point just in case, selected Y to run fsck and it came back with trylock failed while locking the cluster. Ok, so I tried stopping oc2b and got the message, that heartbeat is still active. I saw online that this is a common message that happens, but didn't find how to get around that. Anyway, it would not let me run the fsck at that point. It was getting late, so I brought the DB's back on line and I am still logging those errors of course. What if any steps did I miss here? I am new to RAC and OCFS2 so maybe I missed something here to be able to run the fsck command. Not sure if this is the correct forum for this, but I though I would start here. Confused Thanks for any info.
Re: RAC and OCFS2 [message #593761 is a reply to message #593760] Tue, 20 August 2013 12:08 Go to previous message
Messages: 26766
Registered: January 2009
Location: SoCal
Senior Member
submit Service Request to MOS
Previous Topic: import script doesn't call dump file & oracle_sid
Next Topic: Need Help for write script
Goto Forum:

Current Time: Sun May 19 10:02:12 CDT 2024