Home » Developer & Programmer » Reports & Discoverer » REP-0736 Uncompiled units exists - in Oracle reports builder 12c (Oracle Reports builder, 12C, Windows 10)
REP-0736 Uncompiled units exists - in Oracle reports builder 12c [message #682733] Thu, 12 November 2020 21:52
Messages: 1
Registered: November 2020
Junior Member

I am facing very unusual issue. I have Oracle reports (RDF) files developed in Oracle reports builder 6i version. We upgraded them to 12C , an year back using migration assistants.
Now, we are enhancing the application and I introduced new SQL blocks, new frames, fields in the exisisting RDF file developed in 6i.

The issue is, some piece of code in FUNCTIONBODY or in SQL statements turning to JUNK values after saving and reopening the RDF file like attached snap.

This in turn causing the error REP-0736 - uncompiled units exists. But when I correct the fields program units or SQL statements again and recompile, report is compiling fine.
I tried removing the fields, redid with no luck. Tried in different WIN 10 PC, still issue.

What is causing this issue and how could I fix this? Kindly help.
Previous Topic: Dynamic title in OAC Reports
Next Topic: Library webutil cannot be found
Goto Forum:

Current Time: Wed May 29 12:59:29 CDT 2024