Home » Server Options » Replication » replication problem
replication problem [message #75235] Wed, 07 August 2002 16:04 Go to next message
uly88
Messages: 2
Registered: August 2002
Junior Member
can you please help me: the problem is that i can not see one table in the replication manager when i want to add a replication object(s). only that table in that schema..the others i can see them and add them..

thanks...
Re: replication problem [message #75236 is a reply to message #75235] Thu, 08 August 2002 10:06 Go to previous message
David Simpson
Messages: 29
Registered: May 2002
Junior Member
You won't be able to add a table to be replicated if it does not have a primary key - this could be your problem.

I generally avoid using the Replication Manager GUI when setting up Advanced Replication - though I use it to manage replication once it is setup.

You might want to look at the sample scripts on my web site:
http://www.dotcomsolutionsinc.net/products/repgen/repgen_files.html

I recommend paying special attention to the configuration of your conflict resolution setup. An incorrect conflict resolution setup will cause data divergence between the replicated systems - which is not desirable. Here is an example of the script where I setup conflict resolution:
http://www.dotcomsolutionsinc.net/products/repgen/repgen_example_repaddtable1.html

David Simpson
www.dotcomsolutionsinc.net
(Oracle Replication Consulting & Tools)

Previous Topic: Snapshot replication without deletes ?
Next Topic: to update my remote database sever through email
Goto Forum:
  


Current Time: Mon May 16 06:27:59 CDT 2022