Home » Developer & Programmer » Reports & Discoverer » Oracle Reports in 9iAs
Oracle Reports in 9iAs [message #89734] Tue, 13 July 2004 02:13 Go to next message
rajini
Messages: 3
Registered: July 2004
Junior Member
hi,

I am getting this error when i tried to run reports in 9iAs

"REP-3000:Internal Error Starting Oracle Toolkit"

i tried changing Display settings.

But couldn't run any report.

Thx

Rajini
Re: Oracle Reports in 9iAs [message #89742 is a reply to message #89734] Wed, 14 July 2004 23:30 Go to previous messageGo to next message
Himanshu
Messages: 457
Registered: December 2001
Senior Member
Hi,
Here are two scenarios which might be causing Problem.

1)Running Report on Web in 9iAS V2 Environment
You have successfully installed 9iAS V2 on your Unix machine. When attempting to run a report through a URL you get the following error:
"Oracle Reports Server CGI - Report Job has terminated with error.
Reports Server Replies:
REP-3000: Internal error starting Oracle Toolkit."

Solution:
To ensure that the DISPLAY environment variable is set correctly in a 9iAS V2 environment, or any environment where a Reports9i server is being used, you have to add an entry referencing this variable in the reports.sh script.

This file is found in the ORACLE_HOME/bin directory.

2)Reports in-process server gives REP-3000 error when running report
When running a sample report using the Reports in-process server, the following error message appears in the browser:
REP-3000: Internal error starting Oracle Toolkit.

Solution:
Ensure that the DISPLAY environment variable is set correctly in the following configuration file: $ORACLE_HOME/j2ee/OC4J_BI_Forms/config/oc4j.properties

The default DISPLAY entry is as follows: oracle.display=:0.0

You need to change the default entry to a machine with a valid X server.
For example, to use the X server running on myserver:0.0,
you would change the default entry to: oracle.display=myserver:0.0
After these changes are completed, it is necessary to restart the Forms/Reports OC4J instance.
You can either restart this using Enterprise Manager, or from the command line using the following commands:
$ cd $ORACLE_HOME/opmn/bin
$ ./opmnctl stopproc type=oc4j instancename=oc4j_bi_forms
$ ./opmnctl startproc type=oc4j instancename=oc4j_bi_forms

HTH
Regards
Himanshu
Re: Oracle Reports in 9iAs [message #90180 is a reply to message #89742] Tue, 30 November 2004 00:12 Go to previous message
Srini
Messages: 28
Registered: November 2000
Junior Member
Guys,

I have same issue running AS10g reports.
When i try to start the reports server, it gives me the error message

An error occurred while restarting "Reports Server: rep_uscoluxdv10".
An error occurred while talking to OPMN. Could not find entity for "rep_uscoluxdv10".
For more information, look at the logs using the related link below.

Please help.

- Srini
Previous Topic: Joins in Discoverer Desktop
Next Topic: Prt for printing a report in Landscape format
Goto Forum:
  


Current Time: Wed Feb 21 13:28:20 CST 2024