Home » Developer & Programmer » JDeveloper, Java & XML » Message Internal Error: Inconsistent catalog view
Message Internal Error: Inconsistent catalog view [message #92285] Tue, 18 May 2004 13:07 Go to next message
Messages: 104
Registered: October 2000
Senior Member

We are using Oracle user defined types in our application.Inorder to increase the coulmn size in the Oracle Object,i have modified the code and recreated the Object in Database.We are using this object in Stored procedure, when i run the application i got error message..

Problem in Stored procedure java.sql.SQLException: Internal Error: Inconsistent catalog view                                      
java.sql.SQLException: Internal Error: Inconsistent catalog view                                                                   
        at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:187)                                                        
        at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:229)                                                        
        at oracle.sql.StructDescriptor.initMetaData1_9_0(StructDescriptor.java:897)                                                
        at oracle.sql.StructDescriptor.initMetaData1(StructDescriptor.java:864)                                                    
        at oracle.sql.StructDescriptor.isInstantiable(StructDescriptor.java:508)                                                   
        at oracle.sql.STRUCT.<init>(STRUCT.java:107)                                                                               
        at oracle.jdbc.oracore.OracleTypeADT.createObjSTRUCT(OracleTypeADT.java:2098)                                              
        at oracle.jdbc.oracore.OracleTypeADT.toDatum(OracleTypeADT.java:289)                                                       
        at oracle.jdbc.oracore.OracleTypeADT.toDatumArray(OracleTypeADT.java:327)                                                  
        at oracle.jdbc.oracore.OracleTypeUPT.toDatumArray(OracleTypeUPT.java:143)                                                  
        at oracle.sql.ArrayDescriptor.toOracleArray(ArrayDescriptor.java:771)                                                      
        at oracle.sql.ARRAY.<init>(ARRAY.java:118)                                                                                 
        at com.ponl.servicecontract.action.user.RateSheetAC_SCF07A.execute(RateSheetAC_SCF07A.java:1309)                           
        at com.ponl.tca.action.RequestProcessor.processActionPerform(RequestProcessor.java:68)                                     
        at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:266)                                            
        at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1292)                                                 
        at org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:510)                                                   
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:760)                                                            
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)                                                            
        at com.evermind.server.http.ServletRequestDispatcher.invoke(ServletRequestDispatcher.java:721)                             
        at com.evermind.server.http.ServletRequestDispatcher.forwardInternal(ServletRequestDispatcher.java:306)                    
        at com.evermind.server.http.HttpRequestHandler.processRequest(HttpRequestHandler.java:767)                                 
        at com.evermind.server.http.HttpRequestHandler.run(HttpRequestHandler.java:259)                                            
        at com.evermind.server.http.HttpRequestHandler.run(HttpRequestHandler.java:106)                                            
        at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Worker.run(PooledExecutor.java:797) 


Please help in order to get rid of this error message..


Best Regards,

Re: Message Internal Error: Inconsistent catalog view [message #92312 is a reply to message #92285] Fri, 28 May 2004 01:51 Go to previous messageGo to next message
Vano Beridze
Messages: 1
Registered: May 2004
Junior Member
This exception is thrown when a user calling the stored procedure does not have an execute permission on that type.

For example if you have type defined as
create type MyObject
a number;

You should also have
grant execute on MyObject to myUser;

Hope this helps
Re: Message Internal Error: Inconsistent catalog view [message #354183 is a reply to message #92312] Thu, 16 October 2008 21:27 Go to previous messageGo to next message
Messages: 2
Registered: October 2008
Junior Member
Hi I had similar issue and I solved it by replacing the old version of JDBC driver with new JDBC driver.

The newer version of jar which I used is classes12_V10.1.0.4.jar. Not sure of the older version.

Hope it helps.
Re: Message Internal Error: Inconsistent catalog view [message #419484 is a reply to message #92285] Sat, 22 August 2009 23:57 Go to previous message
Messages: 1
Registered: August 2009
Junior Member
I am not sure about your particular setup, but we are using OCI to connect to the database, and for that reason, we were told not to use classes12.jar, since it conflicts with ojdbc14.jar. So, I was able to add the prefix of the SCHEMA OWNER and it worked.

ArrayDescriptor descriptor = ArrayDescriptor.createDescriptor(
getSchemaPrefix() + ".FILE_CUT_LIST", connection);

You could try this.

When we did not use OCI and obviously we used a thin driver to connect, we used classes12.jar and at that time we did not prefix anything, and it simply worked.

Hope this helps.
Previous Topic: temp tablespace becomes full, not released by JDBC thin client ojdbc14.jar
Next Topic: Varray in Java
Goto Forum:

Current Time: Wed Mar 29 07:59:56 CDT 2023