Home » Developer & Programmer » Precompilers, OCI & OCCI » Pro C & Oracle 9i problem  () 1 Vote
Pro C & Oracle 9i problem [message #94097] Fri, 13 February 2004 11:33 Go to next message
Trisha Knight
Messages: 1
Registered: February 2004
Junior Member
We just migrated to ORACLE 9.2.0.4  from ORACLE 8.1.6.3 several weeks ago.  Some of our users get weird output when they run one of our ProC process with a case statement.  For these users, it does not recognize the case value's and drops straight to the default.  Other users, run the same process and it works.  Can you PLEASE give me some ideas of what to look for?

Thanks in advance!!!

Trisha

 
Re: Pro C & Oracle 9i problem [message #94294 is a reply to message #94097] Sat, 03 July 2004 02:24 Go to previous messageGo to next message
Jamal Al-Hammadi
Messages: 3
Registered: July 2004
Junior Member
When I try to make the rtsora32 with command:
make -f ins_precomp.mk rtsora32
I get the following error:
Linking
cob: error reading: /u01/app/oracle/product/9.2.0.1.0/precomp/lib/cobsqlintf.o
Exit Code: 1

My Oracle version: 9.2.0.1.0
My OS Version : HPUX 11i
My Cobol Version : Micro Focus Cobol 4.1
Re: Pro C & Oracle 9i problem [message #94296 is a reply to message #94294] Mon, 05 July 2004 16:15 Go to previous messageGo to next message
Jai Vrat Singh
Messages: 205
Registered: September 2002
Location: Singapore
Senior Member
Can you check again the purpose to link this file? I case you want it to link for sure, then it must exist and must be readable?

If you can ensure above conditions then it will work fine.
Re: Pro C & Oracle 9i problem [message #94388 is a reply to message #94097] Tue, 28 September 2004 04:01 Go to previous messageGo to next message
subramonian
Messages: 1
Registered: September 2004
Junior Member
Hi ,
I am facing one problem with Oracle 9i and HP-UX 64bit. A simple proc/c++ program to connect to oracle is not working. I use copile option aCC +DA2.0w for 64 bit compilation and 64 bit oracle 9i libraries are linked . But getting core dump at the connection point .. Can you help me ?.
Regards
Subbu
Re: Pro C & Oracle 9i problem [message #94490 is a reply to message #94294] Mon, 20 December 2004 12:01 Go to previous messageGo to next message
Jamal Al-Hammadi
Messages: 3
Registered: July 2004
Junior Member
cob: library not found: -lsocket
Re: Pro C & Oracle 9i problem [message #122743 is a reply to message #94388] Wed, 08 June 2005 06:21 Go to previous message
venkrex
Messages: 1
Registered: June 2005
Junior Member
Hi,

I managed to find a solution to this problem.

I found that the libclntsh.sl.9.0 oracle library was tightly coupled to some other database on the same machine.
You can do this by issuing 'elfdump -c libclntsh.sl.9.0'

Once this library was compiled without dependencies, the problem was solved!
Previous Topic: Pro *C in oracle 9.2.0.2 in hp-ux?
Next Topic: ProC, trace, bind variables
Goto Forum:
  


Current Time: Thu May 19 20:46:43 CDT 2022