Home » Server Options » Streams & AQ » AQ Propagation not happening over remote DBLINK
AQ Propagation not happening over remote DBLINK [message #131910] Wed, 10 August 2005 01:01 Go to next message
Messages: 12
Registered: July 2005
Location: India
Junior Member

Hi Experts,

I have the AQ set up at my Source Database( and also at Target Database(8i).
I have the public db link created in Source Database with SID/GLOBAL_NAME of the target Database.

When i run the EQ scripts at source DB, the data is getting populated in respective Queue tables but it is not propagating to the respective Queue table at target DB and when i looked into the trace file, i came across the following errors,

Tue Aug 9 18:54:08 2005
Errors in file /var/oracle/admin/GMPR99B/bdump/gmpr99b_j000_20045.trc:
ORA-00600: internal error code, arguments: [kwqidrdq: loop], [0], [0], [0], [0], [], [], []
ORA-06512: at "SYS.DBMS_AQADM_SYS", line 5631
ORA-06512: at "SYS.DBMS_AQADM_SYS", line 6056
ORA-06512: at "SYS.DBMS_AQADM", line 895
ORA-06512: at line 1

Please let me know the reason for this error and also about the possible solutions to resolve this.

Thanks in Advance,
Syed Ashfaq Ahmed
Re: AQ Propagation not happening over remote DBLINK [message #156583 is a reply to message #131910] Thu, 26 January 2006 01:30 Go to previous message
Messages: 4
Registered: November 2005
Location: Russia
Junior Member
First of all, visit Metalink to see description of this error. May be you'll need some patches, or there will be the solution.

Second - I am not sure that AQ work properly between 9i and 8i databases. We tried to set up AQ replication beetween 8.1.7 and databases and failed. Migrate your 8i base to 9i and then try this propagation. I think that everithing will be ok.
Previous Topic: Oracle streams + heterogeneous service agent
Next Topic: Http access to Oracle AQ
Goto Forum:

Current Time: Thu Mar 30 15:28:48 CDT 2023